Buffalo TerraStation NAS: Emergency Modus – so wird es behoben… 27

Buffalo TerraStation NAS: Emergency Modus - so wird es behoben...

Hier erkläre ich euch, wie ihr eure Buffalo TerraStation (bei mir eine TS-RXL/R5) wieder aktiv bekommt, wenn ihr keinen Recover USB-Stick habt und das NAS nach einem kompletten Festplattenwechsel nur noch im EM-Modus (Emergency Modus) startet.

 

Nachdem ich schon gestern das NAS auf dem Tisch hatte und alle 4 Platten getauschte werden sollten, wollte das Gerät nicht mehr booten. Mit einem Error und dem rot beleuchtetem Display inkl. der Meldung „EMERGENCY MODE“ wurde ich nach dem starten des Gerätes (dauert bestimmt 5 Minuten) begrüßt.
Sowiet ist das Verhalten normal, denn das System des Gerätes liegt für gewöhnlich min. auf der Platte 1 (bei einem Arry wird es entsprechend mit verteilt).

Viele div. Anleitungen im Netz beschreiben, wie man allg. ein Firmware-Update am Gerät vollziehen kann oder gar das Geräte absichtlich in den EM-Modus versetzt. Nur davon war keine Anleitung passend zu diesem Fehler,  denn bei den Anleitungen wird nicht davon ausgegangen, das man alle 4 Platten gewechselt hat und das gerät schon so startet.

 

Welche Vorraussetzungen?

  • min. 1 Festplatte im Slot 1 (> 500GB)
  • NAS und PC müssen im selben Netzwerk sein (DHCP, Firewall am PC bitte aus)
  • Notwendige Software von Buffalo herunterladen, die zu deinem Gerät passt
    • den aktuellen NAS Navigator2 hier (bis zu deinem Produkt durchklicken)
    • den aktuellen Firmware-Updater – auch hier (bis zu deinem Produkt durchklicken)

     

 ACHTUNG: Alle Daten auf den Platten gehen hier verloren. Also nur durchführen wenn gesichert wurde, oder ihr das Gerät komplett neu einrichtet!

Der weitere Ablauf

  1. passende Software laden und entpacken
  2. prüfe mit dem NAS Navigator2 ob du dein NAS nach dem vollständigen booten überhaupt findest
    Der Navigator sollte dir das Gerät mit dem Status „EM-Modus“ anzeigen, Zugriff auf die Weboberfläche ist nicht möglich
    nasnavi01
  3. wechsel in das Verzeichnis des Firmware-Updaters
  4. In dem entpackten Verzeichnis liegt eine Datei namens LSupdater.ini oder TSupdater.ini, öffne diese und ändern folgendes:

    [Flags]
    Versioncheck = 0                 (bitte von 1 auf 0 ändern)
    NoFormatting = 1

    [SpecialFlags]                     (hinzufügen wenn nicht vorhanden)
    Debug = 1                            (hinzufügen wenn nicht vorhanden)

    Schließe und speichere die Datei.

  5. Starte nun die LSupdater.exe oder TSupdater.exe und klicke im  erscheinenden Fenster mit der rechten Maustaste auf die Titelleiste und wähle „Debug(D)…“
  6. Im „Debug Mode“ Fenster wähle alle oberen Menüpunkte auf der linken Seite und folgende Punkte auf der rechten Seite :
    Rebuild partition table“ : Löscht und erstellt eine neue Partitionstabelle auf dem Gerät.
  7. Schließen Sie das „Debug Mode“ Fenster mit OK, und klicken Sie dann auf „Update“ um das Update zu starten. Das Gerät wird nach dem Abschliessen des Updates automatisch, mehrmals neu gestartet (bitte die Anzeige im Updater beachten!).
  8. Mit dem nächsten Punkt gehts nur weiter, wenn du mit diesem Fehler bestraft wirst:
    Hintergrund dazu:
    Das Gerät möchte keine vorgegebene Partition auf den Platten – ausser sein bekanntes Dateisystem (XFS Dateisystem). Dieses ist aber nicht auf einer neuen Platte vorhanden. Auch wenn keine Partition bzw. kein Dateisystem auf den Platten vorhanden ist, bekomme ich diese Meldung. Somit muss dem Updater noch gesagt werden, das er das passende Dateisystem neu erstellen soll!
  9. Öffne erneut die LSupdater.ini oder TSupdater.ini und ändere:

    [Flags]
    Versioncheck = 0
    NoFormatting = 1

    zu

    [Flags]
    Versioncheck = 0
    NoFormatting = 0

     

  10. Nun startet das Gerät die Update- und Transfer-Prozedur. Nach dem Update bootet es ggf. mehrmals neu.
    Auch hier gilt: Beachtet die Anzeige im Firmware-Updater (dauert mehrere Minuten). Danach ist das NAS wieder wie gewohnt oder wie in der Bedienungsanleitung zu lesen, via Webconsole zu erreichen.

 

Das Webinterface ist auf Japanisch

Wenn ihr das NAS nach dieser Anleitung wieder hergestellt habt und euch auf dem Webinterface anmelden wollt, werdet ihr sehr wahrscheinlich auf japanisch begrüßt.
Hier die Kurzanleitung:

  1. Gebt eure Zugangsdaten ein.

    Benutzer: admin
    Passwort: password

  2. Wählt den 4. Menüpunkt von links in der Kopfzeile aus:

    Den unteren Reiter, dort wo auch Japanese steht, auf diese Werte ändern

  3. 03

    Sprache nach belieben und Zeichensatz auf den untersten Wert

  4. Linken Button betätigen und warten bis das NAS-Interface umgeschaltet hat

 

 

Wenn dir dieser Artikel geholfen hat würde ich mich über eine Spende sehr freuen:

27 thoughts on “Buffalo TerraStation NAS: Emergency Modus – so wird es behoben…

  1. Reply SayingThanks Jul 28,2015 02:04

    Hallo,

    danke für Deinen großartigen Artikel! Jetzt bin ich endlich soweit gekommen, dass die Platten formatiert werden und die Firmware aktualisiert wird. Vermutlich klappt es nun auch mit dem Ende des Emergency Mode.

    Mein Laufwerk wurde ohne Festplatten ausgeliefert. Ich habe nagelneue Festplatten installiert. Man sollte meinen, dieser Prozess sei normal und vorgesehen, aber ich stand stattdessen direkt vor einem großen Problem, da das NAS den Emergency Mode partout nicht verlassen wollte. In der Benutzerführung aus meiner Sicht eine glatte sechs. Ich denke, ich werde das NAS nun auch zurückschicken, obwohl es dank Deiner hilfreichen Anleitung am Ende doch noch geklappt hat, aber wenn schon die reguläre Inbetriebnahme einen vor massive Probleme stellt, will ich den Betrieb gar nicht erst kennenlernen.

    Danke nochmal! Du bist mein Held des Tages. 🙂

    • Reply Hendrik Nov 10,2015 09:02

      Hallo,
      gern geschehen. Über den laufenden Betrieb des NAs kann ich leider nichts berichten. Kam es denn nun zur Rücksendung?
      Aber wie dem auch sei.. mal als Held des Tages betitel zu werden, ist auch ganz schön 🙂

  2. Reply Gert Sep 6,2015 12:26

    UFF!!! Danke!!!

    Nachdem mich heute morgen plötzlich aus heiterem Himmel der Buffalo-NAS mit einem EM-Mode begrüßte und kein Zugang mehr möglich war, dachte ich nur: „Nein, nicht schon wieder!“ Es wäre schon der zweite „Büffel“ gewesen, den ich auf den Müll geschmissen hätte.

    Aber dank deiner Anleitung und einem starken Kaffee konnte ich mit der gebotenen Ruhe und strukturiertem Vorgehen die Sache wieder reparieren.

    Besten Dank nochmals! Gute Anleitungsschreiber sind Helden!

    Gert
    (auch ein Anleitungsschreiber von Beruf)

    • Reply Hendrik Nov 10,2015 09:00

      Oh, Mist. In dem Fall hätte ich mir gewünscht du hättest die Anleitung vorher gefunden oder ich hätte sie früher geschrieben. Ich hoffe das du wegen dem EM Mode nicht wirklich deine 1. Station entsorgt hast…

  3. Reply Alter Schwede Sep 21,2015 15:28

    Lieber Autor,

    großes Lob!

    Nur leider, und dafür kannst du nichts, ist meine TS nicht mehr in der Downloadseite gelistet. Erst ein Anruf bei der Hotline erbrachte, dass ich die Firmware erhalten kann. Nun warte ich auf die Mail…

    Weiterhin wurde mir auch schon auf etwas hartnäckige Nachfrage bestätigt, dass meine TS-HTGL/R5 auch mit SSDs ausgestattet werden kann. Max. 1 TB pro Platte, ich werde es mal mit SanDisk Ultra II SSD 480GB SATA III probieren. Die TS hat SATA II, aber die Platten sind ja zum Glück abwärtskompatibel.

    Mangels PayPal-Konto kann ich leider keine Spende hinterlassen.

    Gruß
    der alte Schwede

    • Reply Hendrik Nov 10,2015 08:59

      Zum Glück konnte scheinbar der Service von Buffalo in deinem Fall weiterhelfen. Schade das die Hersteller „alte“ Daten immer öfters so schnell aus ihren öffentlichen Archiven entfernen.

  4. Reply Joerg Nov 3,2015 11:31

    Grazie Mille für diesen Artikel.
    Das manuelle Editieren von ini-Dateien ist so retro, dass es fast schon wieder Spaß gemacht hat. 😉

    Made my day!

  5. Reply Björn Dez 29,2015 18:59

    Ich habe mal eine frage ich habe die nas ls-chl v2 sie ist im em modus ich habe alles versucht und alles gelesen was es zu lesen gibt vielleicht hast du ja eine ahnung was ich tun kann ich habe auch deine beschreibung gelesen und befolgt bis zum update das fängt er auch an und dann kommt eine ganz andere fehler meldung und zwar diese hier LS-CHL-EME8B returns an error.(ACP_STATE_FAILURE)Updating is aported ich sag nur hilfe

    • Reply Hendrik Mrz 2,2016 19:48

      Hallo Björn,

      da ich leider keinen Zugriff mehr auf das damalige Test-NAS habe, kann ich zu dem Fehler leider nicht weiter helfen.
      Leider handelt es sich bei dir dazu noch um ein anderes Model.

      Sorry, da muss dann wohl der Support direkt befragt werden.

  6. Reply Wolvereign Jan 3,2016 20:48

    Vielen vielen Dank! Nach weit über zwei Jahren noch „das Um & Auf“!

  7. Reply Jan-Luca Diehl Jan 19,2016 19:33

    Ich schließe mich den anderen nur an, meine Linkstation läuft wieder einwandfrei, ich bin begeistert, du bist auch mein Held des Tages, ich bin schon halb verzweifelt. Vielen Vielen Vielen Dank, ich werde deine Seite auf jedenfall weiterempfehlen, großes Lob 🙂

  8. Reply Carsten Feb 15,2016 23:01

    Auch von mir vielen Dank für die Anleitung. Ich habe allerdings das Problem, dass die Formatierung zwar durchläuft (grüner Balken bis zum Ende),dann aber die Meldung kommt „Formatting failed, Update aborted“. jetzt bin ich wider ratlos :-/ Eine Idee, woran das nun liegen könnte?

    • Reply Hendrik Mrz 2,2016 19:53

      Hallo Carsten,

      puhhhhh leider ist das natürlich nun nicht so einfach. Leider habe ich das NAS nicht mehr im Zugriff und könnte deinen Fehler nicht mal dann nachstellen, da es sehr nach einem Problem beim Abschluss der Formatierung klingt.
      Vllt. mal mit einer anderen Festplatte testen. Möglicherweise ist diese der Übeltäter?

  9. Reply Pascal Mrz 2,2016 18:35

    Gleiches Probleme habe ich auch! Aber bei mir kommt es schon früher…

    • Reply Hendrik Mrz 2,2016 19:53

      Hallo Pascal,

      auch hier würde ich mal den Test mit einem anderen Festplatten-Setup versuchen.
      Über Rückmeldung würde ich mich freuen.

  10. Reply Pirle Apr 7,2016 15:58

    Hallo,

    erstmal ein riesen Dank für die super Anleitung!

    Ich habe aber auch das gleiche Problem wie Pascal und Carsten :/
    Gibt es dazu schon was Neues?

    VG Pirle

  11. Reply Daniele Apr 15,2016 09:31

    Hi Hendrik,

    thanks for this article, these should be the information to include in the official documentation.
    The Terastation was driving me crazy, but following your procedure I’ve been finally able to bring is back to life.
    Two HDD failed on a 6TB RAID5 array last weekend, all the data gone, so I decided to change all the disks… but suddenly it wasn’t possible to reach the NAS anymore. EMERGENCY MODE… File System lost!

    How the hell is it possible on such devices?!? They should be bomb proof!

    Thanks again.
    Daniele

  12. Reply MBKAdmin Mai 25,2016 16:50

    Hallo
    Ich habe 4 neue Festplatten 1TB Western Digital RED in eine TeraStation Pro TS-HTGL/R5 eingebaut. Anschließend habe den TFTP Boot Recovery gestartet. Danach war das NAS bereit zum aufspielen der Firmware.
    Habe alles nach Anleitung abgeändert, aber wenn ich das Update starte, dann bekomme ich noch immer die Meldung „Couldn’t pass to the authentication.Please confirm again admin-password of TS-HTGL-EM7A7
    An was könnte das liegen?
    Wäre dankbar für einen Tipp

  13. Reply Thomas Aug 3,2016 23:16

    Vielen vielen vielen lieben Dank.

    Wollte die Kiste schon aus dem Fenster werfen 🙂

  14. Reply Surfer826 Aug 20,2016 16:36

    Hallo,
    besten Dank an deinen Support. Gerät geht wieder. War 10 Minuten Arbeit. Besten Dank und mach weiter so…!!!!!

  15. Reply Josef Nov 1,2016 17:31

    Hallo,
    bevor ich die Lösung nun ebenfalls anstrebe noch zwei ergänzende Fragen, da der aufgezeigte Ansatz ja beinhaltet, dass ein totaler Datenverlust auf den Platten erfolgt:

    1. Wenn ich vor dem Start meine 4 1GB HDDs entferne und nur eine neue Ersatzplatte einsetze und danach
    die Lösung umsetzte und
    2. danach einen geregelten Shutdown durchführe, um im Anschluss die ursprünglichen Datenplatten wieder einzusetzen
    sowie das NAS erneut zu starten

    ==> Sollte die Methode grundsätzlich funktionieren?
    ==> Werden die urspünglichen Platten datentechnisch nach dem Wiedereinsetzen gelöscht?

    P.S.: Habe eine TS-X4.0TL/R5-EU (TS-XL/R5 Series) mit 4*1TB HDD

    • Reply Hendrik Dez 12,2016 12:41

      Hallo Josef,

      leider kann ich dir diese Fragen nicht beantworten – ich habe keine Buffalo Station mehr zum Testen vorliegen.
      Da die Konfiguration des NAS aber auf den Platten liegt, würde ich mal vermuten, dass deine Station nach dem Tausch auf deine „live-Datenplatten“ dann nicht mehr geht.
      Im schlimmsten Fall kannst du dir damit also auch einen gesamten Datenverlust erfahren. Sichere deine Platten daher vorher, wenn du es wirklich testen willst.

  16. Reply Klaus Lehmann Dez 9,2016 12:21

    hai.
    nette anleitung. ist ziemlich gut 😉
    ich habe so an die 20 (alte!) buffalos wieder zum leben erweckt 😉

    zwei,drei generelle tips:

    1. ich würde immer saubere platten reinnehmen.
    was heisst sauber? mit den herstellereigenen tools den bootblock auf NULL setzen. die meisten festplatten-herstellertools bieten das an! wenn irgendwelche reste sich da anfinden, dann funktioniert ls/tsupdater nicht immer.

    2. in lsupdater.ini oder tsupdater.ini kann man noch mehr para’s reinsetzen.
    z.b. password=
    ich habe leider keine parameter-übersicht, was da alles möglich ist.
    hat jemand eine??? bitte hier veröffentlichen (wenn es erlaubt ist). das interessiert jeden, der mit buffalos näher es zu tun hat…. 😉

    3. wenn es gar nicht geht, sollte man sich beim deutschen(!) http://www.buffalo-technology.de/de/support/support-kontakt/ anmelden(sic), und da kann man um hilfe bitte. NUR dieser suppport rückt die älteren(!) tftp-dateien dann auch heraus, die man zur wiedererweckung des buffalos benötigt.
    info: offiziell sind sie nicht zu bekommen (doch, es gibt eine google-adresse mit stand von 2005-2007…). achtung beim buffalo-support: die anleitungen, die man !dann! bekommt, sind nicht immer logisch!. will sagen: nicht korrekt bei der schritt-für-schritt wiedergabe…. da MUSS man mitdenken 😉
    zum support: NICHT wundern, wenn die leute dort bei adam&eva anfangen. alles brav beantworten, und nach 1-2 tagen wartezeit rücken die auch die benötigte tftp-datei raus! will sagen: es hat keinen sinn, nach einer bestimmten tftp-datei zu fragen, mann muss ERST durch die klaviatur von DEREN frage&antworten durchgehen! also: gedult 😉

    4. wer auf die idee kommt, direkt zu den jappanern zu gehen, soll es lassen. ich war dort, bin an alle tftp-dateien rangekommen, aber diese sind ABSOLUT unbrauchbar! (man sollte nebenbei auch jappanische links lesen können 😉 [buffalo ist ne japp.firma!]

    5. zum thema NAS, im speziellen buffalo und qnap, habe ich mal nen ebay-ratgeber verfasst. evtl für jemanden brauchbar(?). hier der link . http://portal.allegronet.de/pc-service/nas .

    grüße, vom Klaus(i)

Leave a Reply